[OK] Problème avec un script php et l'utf-8

Ici, un problème avec la création de votre script? Besoin d'aide pour concevoir une fonction en particulier? Bref, l'entraide qui n'entre pas dans les autres catégories se fait ici. Les membres peuvent ainsi s'entraider.

[OK] Problème avec un script php et l'utf-8

Messagepar AbraknydeNet » Mer Avr 18, 2012 9:00 pm

Bonjour, alors voila je viens d'installer ce script php .... et le problème que j'ai quand je veux posté une news sur mon site les caractères telle que é à ^ ù ne s’affiche pas correctement voir sur l'images comment je peux régler ce problème merci d'avance

images
Avatar de l’utilisateur
AbraknydeNet
 
Messages: 3
Inscription: Mer Avr 18, 2012 8:55 pm

Re: Problème avec un script php et l'utf-8

Messagepar AbraknydeNet » Jeu Avr 19, 2012 12:44 am

voila avec 2 heure de recherche sur google j'ai enfin trouver mon erreur il me manquer un :

Code: Tout sélectionner
mysql_query('SET NAMES "UTF8"');


:D
Avatar de l’utilisateur
AbraknydeNet
 
Messages: 3
Inscription: Mer Avr 18, 2012 8:55 pm

Re: Problème avec un script php et l'utf-8

Messagepar tckalexon » Mar Juil 17, 2012 7:44 pm

Code: Tout sélectionner
à = à
é = é
^ = ˆ
@livingxworld - L?W.fr - Hébergeur Type 1K. termine en 16 janvier 2013
VPS entreprise Debian squeeze 6.0.4 X64 gamme 2013
Avatar de l’utilisateur
tckalexon
 
Messages: 18
Inscription: Lun Juil 16, 2012 10:52 pm
Localisation: Paris

Re: Problème avec un script php et l'utf-8

Messagepar Shinix » Dim Aoû 19, 2012 12:26 am

Bonjour,
sinon tu pouvais tout simplement encoder tes variables ( utf8_encode et utf8_decode).
Avatar de l’utilisateur
Shinix
 
Messages: 159
Inscription: Dim Jan 14, 2007 12:25 pm
Localisation: Genève


Retourner vers Entraide générale



Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités