[OK] Version php dépassée

Vous souhaitez nous faire part de vos idées pour améliorer nos services? Nous vous invitons à nous les soumettre et nous étudions chaque proposition avec soin. Vous pouvez également donner votre avis sur l'ensemble de nos services.

[OK] Version php dépassée

Messagepar ybar » Jeu Jan 06, 2011 3:25 pm

Bonjour,
Sauf erreur de ma part, je pense que votre version php est toujours la 5.2.14 !
Or la version 5.3.4 du 10 dec 2010 est stable...
Pensez-vous faire la mise à jour ? (j'ai un composant Joomla qui exige 5.2.3)
Merci de votre réponse
Avatar de l’utilisateur
ybar
 
Messages: 2
Inscription: Jeu Jan 06, 2011 2:54 pm
Localisation: Belgique

Re: version php dépassée

Messagepar Dakin Quelia » Jeu Jan 06, 2011 3:29 pm

Bonjour ybar,

Tout d'abord, je te souhaite la bienvenue parmi nous. :)

Pour le moment, ce n'est pas en projet de changer. Car beaucoup d'utilisateurs ont des modules/plugins et des scripts qui tournent sur la version actuelle et si on en changeait subitement, Il y aura moultes sujets. Mais à terme, on mettra à jour mais pour le moment, ce n'est pas à l'ordre du jour, je pense. ;)

A bientôt,
Pas de support par message privé (mp) ou mail.
Avatar de l’utilisateur
Dakin Quelia
Staff
Staff
 
Messages: 17128
Inscription: Mer Jan 17, 2007 6:02 pm
Localisation: Belgique

Re: version php dépassée

Messagepar ybar » Jeu Jan 06, 2011 3:32 pm

ok merci quand même de m'envoyer un mail quand ce sera fait.
ps) dis-moi aussi comment je dois faire pour passer ce post comme résolu !
Avatar de l’utilisateur
ybar
 
Messages: 2
Inscription: Jeu Jan 06, 2011 2:54 pm
Localisation: Belgique

Re: version php dépassée

Messagepar Dakin Quelia » Jeu Jan 06, 2011 3:33 pm

Nous ne pourrons t'envoyer un mail qu'à toi. Mais si nous le faisons un jour le changement, tout le monde en sera informé soit par le biais d'une annonce soit par mail.

Quant au résolu, il y a un menu déroulant en bas du sujet. ;)
Pas de support par message privé (mp) ou mail.
Avatar de l’utilisateur
Dakin Quelia
Staff
Staff
 
Messages: 17128
Inscription: Mer Jan 17, 2007 6:02 pm
Localisation: Belgique

Re: version php dépassée

Messagepar ericc » Ven Jan 28, 2011 3:25 pm

Bonjour

Je suis désolé de répondre à un sujet déjà clos mais j'ai exactement la même requête: A savoir que j'aimerais avoir php 5.3

Php 5.2 est maintenant en fin de support depuis le 10 Décembre (voir : http://www.php.net/archive/2010.php#id2010-12-16-1 )
et de plus en plus de scripts et framework nécessite la version 5.3 pour fonctionner correctement ( FatFree http://fatfree.sourceforge.net/ , Symfony 2.0 http://symfony-reloaded.org/ pour n'en citer que quelques uns)

Je comprend qu'il est difficile de changer brutalement de le version de PHP, mais je ne pense pas qu'il y ait beaucoup d'incompatibilité en la version 5.2 et 5.3.

Ne serais ce pas possible d'envisagé une solution comme avait fait free.fr lors du passage de 4.x vers 5.x -> un simple fichier texte à la racine du site contenait la version de php que l'utilisateur souhaitait utiliser (je ne me souviens plus des détails, je peux rechercher si c'est nécessaire) ?
L'avantage, c'est que l'utilisateur peux choisir sa version de PHP (5.2 ou 5.3) et revenir en arrière simplement s'il y a un problème, sans votre intervention.

Il est tout à fait possible de faire fonctionner plusieurs version de PHP sur un même serveur apache (une simple recherche Google avec "multiple php versions apache" comme mots clés retourne plus de 100 000 liens)

ericc
Ca va aller, j'ai du papier
Avatar de l’utilisateur
ericc
 
Messages: 178
Inscription: Jeu Mai 24, 2007 7:22 pm

Re: version php dépassée

Messagepar Dakin Quelia » Ven Jan 28, 2011 3:27 pm

Bonjour ericc,

Comme déjà dit, c'est prévu dans notre liste de choses à faire mais nous avons pour le moment d'autres priorités.

Mais dès que nous aurons fait le passage, nous le ferons savoir aux clients.

Quant au fait d'avoir plusieurs versions php, c'est possible mais ce n'est pas la meilleure idée qui soit. Oui, Free.fr le fait grâce au fichier .htaccess. ;)

A bientôt,
Pas de support par message privé (mp) ou mail.
Avatar de l’utilisateur
Dakin Quelia
Staff
Staff
 
Messages: 17128
Inscription: Mer Jan 17, 2007 6:02 pm
Localisation: Belgique


Retourner vers Vos suggestions, nos projets



Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités